Delays on outgoing emails
Incident Report for Receptive
Resolved
Queue is now running normally
Posted Mar 09, 2016 - 16:30 UTC
Investigating
There is currently a delay on queued emails and webhooks, we're investigating
Posted Mar 09, 2016 - 15:22 UTC