Viewing team member priorities not working
Incident Report for Receptive
Resolved
Fix is now pushed to live
Posted Jun 17, 2016 - 15:27 UTC
Identified
We're releasing a fix soon
Posted Jun 17, 2016 - 15:08 UTC