Outbound emails - some delays
Incident Report for Receptive
Resolved
Email queue is now cleared, thanks for your patience
Posted May 31, 2017 - 09:04 UTC
Identified
There is some backlog of outgoing emails due to a queue being stopped. No data is lost, we're processing the queue now
Posted May 31, 2017 - 08:14 UTC