Email delays
Incident Report for Receptive
Resolved
The backlog in one of the mail queues is now cleared, notification emails are flowing again. It seems that the queue slowed down at about 01:20 UTC. We're going to keep investigating to reduce the likelihood of a repeat. Thanks for your patience.
Posted Jul 29, 2016 - 10:13 UTC
Investigating
Possibly some email queues are being processed more slowly than usual. We're investigating.
Posted Jul 29, 2016 - 09:46 UTC